The following SecuriSync clients are available:

The following OS and platforms are supported:

Desktop

  • Windows: 7, 8, 8.1, 10
    Internet Explorer 9 is required to run SecuriSync.
    For Windows XP and Windows Vista  older SecuriSync client can be used. 
    Note: this client version is no longer supported. We strongly recommend using the latest SecuriSync client or upgrade your OS version.
  • Mac: 
    The latest app supports High Sierra, Mojave, Catalina.
    App v. 2.36.5 works on Yosemite, El Capitan.
    App v. 2.13 works on Lion, Mountain Lion, Mavericks, Sierra
    App v. 2.10 and older work on Snow Leopard
    Older SecuriSync version 2.13.53 misses Change Folder Location, Unlink Account, and Multiple folders backup. It is available for download (Note: the stability of work is not guaranteed). It is available for download:

Web

  • Chrome
  • Firefox
  • Internet Explorer (11 & higher)
  • Opera
  • Safari

Mobile

  • Compatible with iPhone, iPad, and iPod touch, iOS 9.0+ is supported
  • Latest version of SecuriSync Android App requires Android 4.4+ (Next update would require Android 6.0+)
    App v. 2.12 and older work on Android 2.1+ (including Amazon Kindle Fire)

Note: If you are not able to login to the SecuriSync mobile app, make sure AdBlock filtering on your mobile device is disabled or domain  intermedia.net  is added to whitelist.