In this article, you will find the instructions on how to archive mailbox data in Outlook 2011 and Outlook 2016 for Mac. Archiving is available when you enable the rule which is set up and run in your mailbox. The Archiving rule will help you move the data from the server to a folder on your computer to reduce the mailbox size.

If you are using Outlook on PC read the Knowledge Base article How Does Outlook Archiving Works? for more information.

To start using local Mac archiving, you would need to create the Archive folder. To create Archive folder:

Outlook 2011 for Mac

You would need to create Archive folder on the local computer. To unhide On My Computer folder:

In Outlook 2011 > click on the Outlook menu at the top of your screen > choose Preferences > uncheck the box Hide On My Computer Folders.

To create local archive folder right-click (or ctrl-click) on the On My Computer heading > choose New Folder.

Outlook 2016 for Mac

Important: Archive button is available only on Exchange 2016

To create Archive archive folder choose one or more messages that you would like to archive > chose Archive on the ribbon. As soon as you choose Archive, you will get a prompt The "Archive" folder for "Microsoft" does not exist > to proceed click Continue button. The Archive folder will be automatically created. 

To set up archiving rule

  1. In Outlook 2011 or 2016 for Mac, go to Tools > Rules.
    • Alternatively, go to Rules from the ribbon and select Edit rules:

      outlook 2011 rules
  2. Select Exchange on the left pane menu and click on '+' to add a new rule:

    outlook 2011 rules exchange
  3. Give the rule a name and specify the conditions using drop-down lists as follows:
    • If all conditions are met: Selected.
    • When a new message arrives: Date Received | is greater than | enter any number | days old.
    • Do the following: Move Message | any folder on your computer.
    • Do not apply other rules to messages that meet these conditions: Enabling this option is up to you and depends on your other rules.
    • Enabled: Checked.

      outlook 2011 rules
  4. Click OK to save the rule.
  5. Apply the rule by clicking on the source folder, then Rules > Apply > Name of the rule.
    Apply Rule
  6. To export the data from Archive folder navigate to File > Export. On dialog window choose types of items that should be included in the archive file. Click Continue.
    Export Types
  7. On next dialog window type the name of the archive file and select the location on your computer, where the file should be stored. You may add the tags optionally. Click Save.
    Name of the file 
    Note: When you run this rule for the first time, archiving may take a lot of time to complete depending on your mailbox size.
  8. After the task completed you will find the .olm file with your mailbox items saved on the computer. 
    olm file
  9. Confirm that items are in the file. Navigate to File > Import > Outlook for Mac archive file > choose the file. File will be displayed in the list of folders. If all items are in place, you may empty the Archive folder.