You can create an application from within Microsoft Visual Studio by following these steps (they may differ for different versions, this article describes how to do it in Microsoft Visual Studio 2002 and 2008):

Microsoft Visual Studio 2008:

  • Open Visual Studio.NET and choose File > New Web Site.
  • When dialog window appears, choose 'Language' and 'Template'. In our case we want to choose Visual C# > ASP.NET Web Site.
  • In 'Location' field choose 'HTTP' and type the address where your project will be created, for example http://yourdomain.com/ApplicationName. The files will be plased on the server using FrontPage extensions and you need to make sure that you have already installed them on your account via "HostPilot Control Panel > Web/FTP Server > Web Server > Website Tools > FrontPage 2002 > Install/Uninstall").
  • After Visual Studio connects to the server, it will upload your application files into D:\FTP\Account\Htdocs\ApplicationName folder and this folder will be set up as an application in IIS. 
  • Now you can write some code for your application and when it is ready, compile it using Build > Build Web Site and pulish on the we server using Build > Publish Web Site. When it's done, the application can be accessed via browser at http://yourdomain.com/ApplicationName.

You can also publish an existing ASP.NET Web Site or Project located on your file system using Build > Publish ApplicationName.

Microsoft Visual Studio 2002: 

  • Open Visual Studio.NET and choose File > New > Project.
  • When dialog window appears, choose your Project Type (on the left) and Template (on the right). In our case we want to choose Visual Basic Projects > ASP.NET Web Application.
  • In 'Location' field type the address where your project will be created, for example http://yourdomain.com/ApplicationName. You also need to select "Transfer via FrontPage extensions" (make sure that you have already installed them on your account via "HostPilot Control Panel > Web/FTP Server > Web Server > Website Tools > FrontPage"), transferring via UNC names will not work.

 

  • After Visual Studio connects to the server, it will upload default project files to your site and the folder where this project is located (in our case it is "ApplicationName") will be set up as an application in IIS.

Now you can write some code for your application and when it is ready, compile it using Build > Build Solution. When it's done, the application can be accessed via browser at http://yourdomain.com/ApplicationName/WebForm1.aspx (WebForm1.aspx is the default form which Visual Studio.NET uploads to the server).